Honda Goldwing Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter #1 (Edited)
I've recently had the right saddlebag go from difficult to time consuming getting it to latch. I've searched several forums and most seem to address difficulty in opening the left saddlebag. I don't have any issues in opening either saddlebags or trunk, just getting the right side to latch.

Has anyone had this issue, and if so please let me know if it is a simple adjustment before I have a Goldwing running down the road with duct tape holding the bag closed. :(

Edit: 2010 1800
 

·
Registered
Joined
·
45 Posts
Not to sound dumb.What is stopping it from latching.
Rubber seal, latch bent,
I know on my 81. Seal's are bad and getting them in their sweet spot.
Is a hassle..
 

·
Premium Member
Joined
·
23,769 Posts
There is nothing worse than packing some items in the bags, closing the lids, getting set in the seat and starting the bike only to have the " OPEN TRUNK!!!! " flashing on the display. If you haven't done it, spray some Electrical Contact " Grease " into the latch mechanisms. Look for any abnormal rubbing point on the bag seal and lid perimeter. I know you have probably done this but do it again to ease my conscious.
 

·
Registered
Joined
·
24 Posts
I've recently had the right saddlebag go from difficult to time consuming getting it to latch. I've searched several forums and most seem to address difficulty in opening the left saddlebag. I don't have any issues in opening either saddlebags or trunk, just getting the right side to latch.

Has anyone had this issue, and if so please let me know if it is a simple adjustment before I have a Goldwing running down the road with duct tape holding the bag closed. :(

Edit: 2010 1800
I take it it's an 1800 when you close it make sure theres nothing in the way. I the door open flashes I just slap the lid and it's gone. You can check and make sure all the screws are tight on the mechanismn if they are loose that can also be an issue
 

·
Registered
Joined
·
74 Posts
Discussion Starter #5
There is nothing worse than packing some items in the bags, closing the lids, getting set in the seat and starting the bike only to have the " OPEN TRUNK!!!! " flashing on the display. If you haven't done it, spray some Electrical Contact " Grease " into the latch mechanisms. Look for any abnormal rubbing point on the bag seal and lid perimeter. I know you have probably done this but do it again to ease my conscious.
The latch does not appear to be bent, and I don't see anything stopping it from latching. The seals are in good shap, and it closes easily to where it appears it should latch, but it doesn't. I haven't checked the screws on it as Top suggested, and as soon as I close here I will check them and recheck the other items that were mentioned.

Thanks for the responses, and when I find out what the issue is, I will post it.
 

·
Registered
Joined
·
74 Posts
Discussion Starter #6
Looks like it is the latches on the outside cover. I loosened the screws (one wasn't very tight) and moved them out what little bit I could and it closes better, but not like the left side. It still releases easily and no open saddle bag light.
 

·
Registered
Joined
·
24 Posts
Thats probably as good as it gets , if it's still under warranty take it in and have them adjust to your satisfaction or replace it
Top
 
1 - 7 of 7 Posts
Top