Honda Goldwing Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi All

I have a 2004 Gold Wing for some reason I do not have any Turn Signal, Horn or Breaklighjts. I have check all fuses, relays, conections and wires. Has anyone had simmular problem and what is salution:confused:
 

·
Super Moderator
Joined
·
7,673 Posts
There's a chance you may have a bad ground connection.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Thank You Trike Lady fror responding

Good news is I found the problem
Bad news is I will never tell what it was as it woud incrimanate me!:mad::(:confused::eek:
 

·
Super Moderator
Joined
·
9,855 Posts
Thank You Trike Lady fror responding

Good news is I found the problem
Bad news is I will never tell what it was as it woud incrimanate me!:mad::(:confused::eek:
Come on, fess up. Was it something "dumb". We've all done something similar... Make us feel good!!!
 

·
Premium Member
Joined
·
23,775 Posts
OK. We will have to guess what it was. Something embarrassingly obvious...... hmmmm.....I can only remember my idiot oops and your symptoms were different.
 

·
Registered
Joined
·
174 Posts
Was it the pfister valve. It can create all kinds of havoc if it blocks the goesinta.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
No way will ever tell anyone, Ok I did tell my son because he was there when the problem was discovered, but he has been sworn to total silence, as I told him I brought into this world and I will take you out.
 

·
Premium Member
Joined
·
23,775 Posts
The fool learns from his own mistakes, the wise from the mistakes of others. Help us be wise.
 

·
Registered
Joined
·
470 Posts
Kill switch..I've done it..more than once!:D Never mind..I'm tired; I think you turned the ignition to ACC instead of start...
 
1 - 9 of 9 Posts
Top