Honda Goldwing Forum banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Banned
Joined
·
1 Posts
Discussion Starter #1
Well i picked up and 82 650 maxim basket with 8000 original...fixed it up . sold it for $1000 now upgraded to an 82 interstate.for $1200
sooo temp or fuel gauge does not work. also speedo quit on ride home. fuses are good i have not removed the fairing Yet. wow lots of screws..lol..but polished up the bike pretty well. also exhaust are shot. runs ok but i will rebuild carbs this winter as well as anything else. speedo looks easy but looks like i get to pull fairing to figure out fuel and temp gauges..any help on what to look for . i had everything off from steering back fuel sending unit tests good.
thanks to who ehlp me out ...
Larry B
 

·
Administrator
Joined
·
25,936 Posts
Welcome lbman. Not too much of a trouble shooter, but there's lots of guys and gals here with experience on that model of Wing. You could have something inside the instrument pods that's funky if the sending units are good.
 

·
Super Moderator
Joined
·
9,843 Posts
Welcome to the forum from the Keystone state. Seems to me if you are going to do extensive work on that Wing, you might want to invest in a shop manual. If you check the web you may be able to find one or maybe someone on here has one to sell that does not need it anymore. Good luck and post pics as you go. Ride safe...
 

·
Super Moderator
Joined
·
11,938 Posts
Welcome, fellow Washingtonian. I'm sure somebody will be able to give you some good advice. I picked up a bike from Maple Falls, earlier this year, and I think it is still drying out!
 

·
Super Moderator
Joined
·
15,139 Posts
hello and welcome to GWOF lbman. you have mechanical guages on your 1100 so follow the speedo cable form the front wheel back to the speedo . the cable is probally broken, just replace it
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top