Honda Goldwing Forum banner

1 - 10 of 10 Posts

·
Premium Member
Joined
·
414 Posts
Discussion Starter #1
OK, I bought one of the voltmeters knowing that it wasn't plug-n-play, but splicing wires on my ride scares the bejeezus out of me. Searched the web for a how-to page, but no luck. Anyone done one of these and have any suggestions or lessons learned from the experience?

Oh, and the vented belly pan went on without a hitch thanks to the postings on it here.

Rapier
 

·
Super Moderator
Joined
·
9,855 Posts
Found this comment on another board. Hope this helps..

"No problem ever with water. I mounted mine right above the GW emblem. Also, please consider running the pick up voltage right to the two screw terminals on the fuse block by the battery. Much better place to be checking system voltage."
 

·
Registered
Joined
·
2,835 Posts
You can run the wires from the unit to the ACC. terminal on the fuse box, then you don't have to cut any wires on the bike.
 

·
Premium Member
Joined
·
414 Posts
Discussion Starter #5
Thanks, guys! I'll most likely be doing the installation this weekend, thanks to the sage advice.

Rapier
 

·
Premium Member
Joined
·
414 Posts
Discussion Starter #7
I might have to take you up on that, Chopin! I'dm sure that I'll purchase one in the future, but it would be nice to see one beforehand anyways.

Thanks!
 

·
Premium Member
Joined
·
414 Posts
Discussion Starter #9
The install went as well as I could have expected. Only hitch was that the top/positive screw stripped out. I was able to get it out and found a replacement at Home Depot that worked just fine. And yeah, I replaced both of them just so they'd match! hehe

I mounted it on the frame in the bottom of the right handlebar well as was suggested and the hardest part was just figuring out how to route the wires.

Thank you to all for the sage advice!
 

·
Premium Member
Joined
·
23,776 Posts
The install went as well as I could have expected. Only hitch was that the top/positive screw stripped out. I was able to get it out and found a replacement at Home Depot that worked just fine. And yeah, I replaced both of them just so they'd match! hehe

I mounted it on the frame in the bottom of the right handlebar well as was suggested and the hardest part was just figuring out how to route the wires.

Thank you to all for the sage advice!
Good job Sparky!
 

Attachments

1 - 10 of 10 Posts
Top