Honda Goldwing Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello, this just started today. When I press the off switch my engine will sputter and the oil light will blink before it shuts off. Takes about 5 to 10 seconds before it finally shuts off. It still starts just fine on first press and it hasn't done this before. Anyone know what the problem is?
 

·
Administrator
Joined
·
29,490 Posts
Can't speak for everyone but many of us do not use the kill switch to shutdown, just the key. It is possible that the contacts are a bit corroded and not opening smoothly is my only thought.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Can't speak for everyone but many of us do not use the kill switch to shutdown, just the key. It is possible that the contacts are a bit corroded and not opening smoothly is my only thought.
I did it with the key as well last night and same problem. I haven't put gas in it in a while so I'll do that today and see if it helps.
 

·
Moderator
Joined
·
978 Posts
Kind of like dieseling when engine keeps running for awhile? Might try different spark plugs. You are not using premium gas,, are you?
Good point giumbyredd!! Is there more to the symptoms when it is trying to stop? If it is indeed ‘afterrunning’, you have your throttle plates open too much. Some have compensated for “the vacuum leak” by adjusting the throttle knob in the gas door area. Between the vacuum leak, the idle plate position, and the idle mixture screw adjustment, it will do as you describe. The vacuum leak is a vacuum hose under the carbs. I did have a late 90’s wing with a bad PAIR valve solenoid once. We put a BB in the line to stop his symptoms until he could buy a replacement part.
 
1 - 5 of 5 Posts
Top