Honda Goldwing Forum banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Banned
Joined
·
7 Posts
Discussion Starter · #1 ·
Have had my 1997 SE 1500 Wing in the garage for the month or so hooked up to a battery tender. The battery was still hooked up to the bike while on the battery tender. Started it up today to go for a short ride and noticed the midddle digital display on the dashboard did not come on after I started the bike. Got it warmed up some and during the warm-up the display still didn't appear. Rode it about three blocks and the digital display then appeared. The dash has a digital display in the middle area, not for the speedometer or tach. The digital display is mainly the radio station that is playing and below that is the clock display in numbers. It is not a full digital dash like some other Goldwings have. Have never had this happen before. What would cause the digital display not to appear during initial startup and the warm-up period? Why would it later come on after riding the bike only a few blocks? The display stayed on the reat of the time I rode the bike today. Got it home and turned the bike off then back on with the key and the digital diplay came on immediately like normal. Has any one else had this happen before? Just wondering if I should be concerned or not with this.
 

·
Super Moderator
Joined
·
7,610 Posts
If it has only done it once it may have been moisture.
If it does it many times possible loose connection at the gauge cluster.
 

·
Registered
Joined
·
334 Posts
Just wondering what was the temp. in your garage digital displays sometimes will not show up in cold temp. until electrioncs warms up the crystal display just a thought. Hal
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top