Honda Goldwing Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My 82 Goldwing was running fine then it just stopped, no power to anything :confused:, i checked the battery, battery conections, Main fuse (next to battery) There is power comming out of the main fuse block , but nothing else has power.. Can someone please guide me to the next thing i should check ? Thanks, Rick
 

·
Premium Member
Joined
·
23,765 Posts
My 82 Goldwing was running fine then it just stopped, no power to anything :confused:, i checked the battery, battery conections, Main fuse (next to battery) There is power comming out of the main fuse block , but nothing else has power.. Can someone please guide me to the next thing i should check ? Thanks, Rick
Someone is going to ask this from you, I can feel it, so we might as well get it over with, " Did you check the kill switch position ? ". Now that we got that out of the way, I'll turn it over to our older Goldwing technicians. Stand by hotrod.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Yeah iv checked everything, correct me if im wrong, but even if the kill switch is in the off position i would still have power to everything else ?? Thanks for getting this started. (the thread not the bike) I wished it was that easy LOL :D
 

·
Registered
Joined
·
123 Posts
I think the next likely culprit after the main fuse is the ignition switch. Check the contacts in the switch base - the contacts get worn eventually.
 

·
Premium Member
Joined
·
23,765 Posts
When you discover the problem, we also discover the problem. The relationship here is symbiotic. We are going to keep at it until we get it.
 
1 - 6 of 6 Posts
Top