Honda Goldwing Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
347 Posts
Discussion Starter · #1 ·
I just ordered it from Garmin for my '08. For those of you who have purchaced this upgrade, are there any enhancements to the functionality, or is it the same old screens with a few new roads added?
 

·
Registered
Joined
·
61 Posts
I got mine a while ago. Haven't used it much, but seems like same interface and options with updated roads.
On a side note. There were problems with original update card. Garmin did the right thing and notified me of problem, credited purchase, then sent me the corrected, updated card for no charge after the problem was straightened out.
Kudos to them!
 

·
Registered
Joined
·
347 Posts
Discussion Starter · #3 ·
I got mine a while ago. Haven't used it much, but seems like same interface and options with updated roads.
On a side note. There were problems with original update card. Garmin did the right thing and notified me of problem, credited purchase, then sent me the corrected, updated card for no charge after the problem was straightened out.
Kudos to them!
I've found a few things online about "glitches" with their update and was hoping the problem had been resolved. Since they made it right with you and because I ordered directly through Garmin, I can only hope they updated those that were already on the shelf as well.
 

·
Premium Member
Joined
·
24,643 Posts
I found the updated version (from Honda) improved the sytem quite a bit, but mine's a Canadian version so it left lots to be desired from the get go. More detail and more of the newer roads on it. Still shows the highway to my place as an 'unverified road' though, and when it does show, it's only range and township not Hwy 2:confused:
 

·
Registered
Joined
·
347 Posts
Discussion Starter · #5 ·
I finally worked up the nerve to install the update. Followed the instructions from Garmin and the process only took about 2 minutes. Checked and sure enough the new firware version 4.6 and Mar/2011 maps are there.

I've read some negative stuff on other forums but all is well so far. I did contact Garmin Support about some of the things I'd read and they did confirm via e-mail that there is a problem with the latest firmware whereas you cannot insert a space when entering a city name that begins with "St" (i.e. St. George, St. Louis, etc.). once you enter "St", the space bar dims and cannot be selected. You then have to scroll through every city in the country that starts with "St" until you find the one you want.

Hope to get it out this weekend to give it the 'ol smoke test.
 

·
Premium Member
Joined
·
24,120 Posts
I finally worked up the nerve to install the update. Followed the instructions from Garmin and the process only took about 2 minutes. Checked and sure enough the new firware version 4.6 and Mar/2011 maps are there.

I've read some negative stuff on other forums but all is well so far. I did contact Garmin Support about some of the things I'd read and they did confirm via e-mail that there is a problem with the latest firmware whereas you cannot insert a space when entering a city name that begins with "St" (i.e. St. George, St. Louis, etc.). once you enter "St", the space bar dims and cannot be selected. You then have to scroll through every city in the country that starts with "St" until you find the one you want.

Hope to get it out this weekend to give it the 'ol smoke test.
I was offered this update by a fellow rider. My response so far has been " You lead, I'll follow. "
 

·
Registered
Joined
·
27 Posts
Not so good for me

I have the 2011 update. Was told in January to wait till April and get the good new one. Waited till May, ordered, got the 2011 version. Was assured it's the post-bug version.

Install didn't take. Brief flash of "transferring data" but no update. Called Garmin, got thru quickly. Advised that there are still bugs and I should have waited, new version any day now. I think they always say that.

Listened to problem, told me I need to reset the Navi. Two-person job (%#%#). Just use a paperclip to push the reset button, then turn on the ignition. Should indicate "holding" and then you push in the new CF card.

After all the unscrewing covers, setting up a light source, waiting for wife to get home to help me .... of course the "holding" message doesn't appear and the reset process doesn't work.

Call Garmin again. We agree I should see my dealer. Who tells me to drop the bike off next Tuesday at 0900, no idea when they'll get to it, might be all day, they don't give timed appointments because mechanics might end up idle. I live 50 minutes away by bus, so I guess they want me to hang around there ALL ^#%# DAY. And they charge $95/hour - bet there's a minimum, too.

UPDATE
So ... I decide to try it again a few more times. No joy, and on opening up the box I see that I've broken the reset switch. Not surprising, because the wires are nearly invisibly thin - and that screams Bad Design to me. Luckily I found a guy in town who runs an Indian grocery store, video rental, and electronics repair all out of one tiny store. Fixed it for me for $10. Needed his super-magnifying glasses to do it.

And ... back home. Three tries and the [email protected]%# thing FINALLY took the update.

TL;DR: The update may require a reset, and the reset button is VERY flimsy.
 

·
Registered
Joined
·
71 Posts
So do you send your dealers bill to Garmin? Or are you expected to pay for the dealer screwing around with an update that should never have been released from Garmin.

After hearing all the negativity, I bought a Zumo, and couldn't be happier.
 
1 - 8 of 8 Posts
Top