no neutral light, no start, 2010 1800 - Page 4 - Honda Goldwing Forums
 14Likes
Reply
 
Thread Tools Display Modes
post #31 of 33 (permalink) Old 07-05-2018, 08:45 PM
Lifetime Premium
 
Chopin's Avatar
 
Join Date: Nov 2009
Location: Centreville, VA 2008 Pearly White.
Posts: 22,816
I try to get all them to spray WD-40 , but they just keep laughing.

Sent from my E6830 using Tapatalk

Lee.
Darksider since I finally saw the Light.
Chopin is online now  
Sponsored Links
Advertisement
 
post #32 of 33 (permalink) Old 07-05-2018, 10:45 PM Thread Starter
Senior Member
 
Keefer269's Avatar
 
Join Date: May 2014
Location: Lakehills,Texas
Posts: 415
Quote:
Originally Posted by Chopin View Post
I try to get all them to spray WD-40 , but they just keep laughing.

Sent from my E6830 using Tapatalk
I say use both, they each serve a different purpose, contact cleaner to dissolve corrosion, wd40 to lubricate and protect against corrosion, idealy tho, they are both a liquid under pressure to blow away and wash away dust and grime.
I opened up the assembly again and used more contact cleaner and more wd40, actuated all the switchs many times, everything is working again. YAY! Back on the road again. Thanks for yalls help!
Chopin and NREMTP like this.

2010 GL1800AC 'Have road, will travel'


Texas hill country + fine rides + single + early retirement = one happy guy
Keefer269 is online now  
post #33 of 33 (permalink) Old 07-07-2018, 10:51 AM
Senior Member
 
NREMTP's Avatar
 
Join Date: Oct 2013
Location: Illinois
Posts: 5,637
Garage
Quote:
Originally Posted by Keefer269 View Post
I say use both, they each serve a different purpose, contact cleaner to dissolve corrosion, wd40 to lubricate and protect against corrosion, idealy tho, they are both a liquid under pressure to blow away and wash away dust and grime.
I opened up the assembly again and used more contact cleaner and more wd40, actuated all the switchs many times, everything is working again. YAY! Back on the road again. Thanks for yalls help!
Great job in solving the problem and thanks for sharing the process with all of us so we can learn too.

Bob
2012 ABS "Red Ghost"
IDMWT 65
NREMTP is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Goldwing Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome